"My Courses" page not loading
Incident Report for U.S. Soccer Learning Center
Resolved
The "My courses" page should now load normally. We apologize for any inconvenience.
Posted over 2 years ago. Jan 26, 2017 - 12:49 CST
Investigating
We have identified a problem loading the "My Courses" page, it is currently being investigated. Thank you for your patience.
Posted over 2 years ago. Jan 26, 2017 - 12:20 CST