Course registration problem- Introduction to Safe and Healthy Playing Environments
Incident Report for U.S. Soccer Learning Center
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 08:17 CDT
Investigating
We are currently investigating this issue.
Posted Jul 28, 2022 - 15:07 CDT
This incident affected: Course Registration.