Problem Processing Payments from non-U.S. locations
Incident Report for U.S. Soccer Learning Center
Resolved
This incident has been resolved.
Posted May 03, 2023 - 13:55 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2023 - 13:02 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 03, 2023 - 12:14 CDT
Investigating
We have become aware of a problem with our third-party credit card processor that is preventing successful payments from devices connecting from outside the United States. Our team is actively investigating possible solutions.
Posted May 02, 2023 - 10:43 CDT
This incident affected: Credit Card Processing.