Technical Issues
Incident Report for U.S. Soccer Learning Center
Resolved
We have found and corrected the issue. Refreshing your page should put you back into the system.
Posted Apr 20, 2020 - 10:40 CDT
Investigating
We are currently experiencing issues loading the Learning Center. Our engineers are engaged and working the issue. We will post updates here.
Posted Apr 20, 2020 - 10:35 CDT
This incident affected: Website, Course Registration, Classrooms, Planning Tool, Learning Center Mobile App, and Credit Card Processing.