Unable to log in to the Learning Center
Incident Report for U.S. Soccer Learning Center
Resolved
Log ins have been restored.
Posted 20 days ago. Jul 31, 2019 - 08:27 CDT
Investigating
We are currently investigating this issue.
Posted 20 days ago. Jul 31, 2019 - 08:14 CDT
This incident affected: Course Registration, Classrooms, and Planning Tool.