Password reset link from log in page throws an error
Incident Report for U.S. Soccer Learning Center
Resolved
This incident has been resolved.
Posted 21 days ago. Jul 02, 2019 - 08:18 CDT
Update
We are continuing to investigate this issue.
Posted 22 days ago. Jul 01, 2019 - 12:19 CDT
Investigating
We are currently investigating this issue.
Posted 22 days ago. Jul 01, 2019 - 11:22 CDT
This incident affected: Website.