Sitewide performance issues
Incident Report for U.S. Soccer Learning Center
Resolved
The problem has been resolved.
Posted Jul 11, 2023 - 08:15 CDT
Update
We have isolated the problem to our integrated video call service. Investigation is ongoing.
Posted Jul 10, 2023 - 15:42 CDT
Update
We are continuing to investigate this issue.
Posted Jul 10, 2023 - 14:27 CDT
Investigating
We are currently investigating a problem with pages loading for many users. We will post updates as more information becomes available.
Posted Jul 10, 2023 - 14:27 CDT
This incident affected: Website.